Ticket #11724 (closed Bugs: Fixed)

Opened 3 years ago

Last modified 2 years ago

Forced subtitles in a video are preffered over external subtitles

Reported by: ezechiel1917 Owned by:
Priority: 4 - Normal Milestone: 11.0
Component: Subtitles Version: GIT
Severity: Normal Keywords:
Cc: Blocked By:
Blocking: Platform: All
Revision:

Description

When playing a video with forced subtitles, these are displayed (and preferred) over external ones (.srt, .sub , etc..). Some time ago (around few months) external subtitles were loading as default subtitles.

Is it possible to fix this to previous state or if it's intended change explain some real situations when should forced subtitles be preferred over external ones, I can't hardly substantiate current behavior. Usually if you have external subs you want them displayed not any other.

Change History

comment:1 Changed 3 years ago by X3lectric

correct me if I'm wrong, aren't forced subtitles same as being hard-coded on video stream?

comment:2 Changed 3 years ago by ezechiel1917

no, forced subtitles are just saying to player it should use these subtitles over any other embedded subtitles. The difference between these and hard-coded subtitles is that you can still turn off forced subtitles if you choose so, they are not hard-coded in video picture.

comment:3 Changed 3 years ago by X3lectric

seems to me than in that case that forced, overrides in your case any other type of subtitle unless its hardcoded.

comment:4 Changed 3 years ago by ezechiel1917

It should override all other embedded subtitles, but not the external subtitles which you add to your folder manually because you want them displayed. Forced subtitles are useful if you want to understand a movie completely in it's original language, that's when they should be displayed and that's why they're tagged forced. Let's say russian parts of english spoken movie should have forced subtitles, because general english speaking person doesn't know russian.

But if you want to watch a movie and want complete translation to any other language, that's when external subtitles comes in. You don't care about any embedded subtitles and forced subtitles as default doesn't make any sense.

comment:5 Changed 3 years ago by dteirney

I thought a forced subtitle just meant that they should be turned on even if the audio being played is that same language. For example, a forced English subtitle stream contains English for all the Spanish audio parts shown in various places in the movie.

comment:6 Changed 3 years ago by ezechiel1917

yup, that's what I've described in my example but with russian parts. However, if you want translation to any other language external subtitles should be automatically selected if they exist.

Examples of usage with external subtitles being preferred: 1 - english speaking person watching english movie - doesn't have any external subtitles (have no need for them). Forced subs automatically selected. (NO CHANGE) 2 - non english speaking person watching english movie - does have external subtitles (needs them because he can't understand the movie or is deaf) - external subs should be automatically selected by default. (DOESN'T HAVE TO MANUALLY CHANGE SUBTITLES IN MENU)

Muxing subtitles to file container itself is time consuming, and even more if you want to edit something directly in subtitles (OCR, change to better translation etc.)

comment:7 Changed 3 years ago by ezechiel1917

So I've done some more testing and it looks like I've screwed a little. The problem is not with forced flag but with default flag of embedded subtitles.

embedded subtitles - default track flag: default | forced track flag: no -> external subtitles displayed
embedded subtitles - default track flag: default | forced track flag: yes -> external subtitles displayed
embedded subtitles - default track flag: no | forced track flag: no -> external subtitles displayed
embedded subtitles - default track flag: no | forced track flag: yes -> external subtitles displayed
embedded subtitles - default track flag: yes | forced track flag: no -> embedded subtitles displayed
embedded subtitles - default track flag: yes | forced track flag: yes -> embedded subtitles displayed

So playing a video in xbmc which has embedded subtitles with default flag set to YES set these subtitles as default while playing and excludes external subtitles from being used as default.

I'm still behind the idea that if external subtitles exists they should be preferred over any embedded subtitles no matter of their flags set.

Name of this ticket should be updated accordingly: Embedded subtitles with default flag set to Yes are preffered over external subtitles

Thanks.

comment:8 Changed 3 years ago by Zarbis

I completely support the idea that existence of external subtitles should override any flags for internal subtitles.

comment:9 Changed 2 years ago by andreofgyn

Man, this is so vital, I just changed to XBMC from NMT and I'm disappointed with the actual behaviour of subtitles.

External subtitles must be prioritized regardeless of the stream flags and any other flag.

comment:10 Changed 2 years ago by mgboom

Any news about this?

comment:11 Changed 2 years ago by Github Janitor

  • Status changed from new to closed
  • Resolution set to Fixed

dvdplayer: prefer external over embedded subtitles with default flag set (fixes #11724)

Changeset: 886a1a438b9cfcda6eca228afd29769f588279f0 By: montellese

comment:12 Changed 2 years ago by Github Janitor

Merge pull request #678 from Montellese/dvdplayer_fix_ext_subs

dvdplayer: prefer external over embedded subtitles with default flag set (fixes #11724)

Changeset: a7d273f2a024bcfd3990527b2cb1334a5508c2e3 By: Sascha Montellese

comment:13 Changed 2 years ago by Montellese

  • Milestone changed from Future / Pending to 11.0
Note: See TracTickets for help on using tickets.