Ticket #13074 (closed Bugs: Obsolete)

Opened 2 years ago

Last modified 21 months ago

playable plugin favorites wont play if they don't contain a query-string

Reported by: sphere Owned by:
Priority: 3 Milestone:
Component: Other (un-categorized if does not fit anywhere else) Version: GIT
Severity: Normal Keywords: plugin, favorites, playmedia
Cc: Blocked By:
Blocking: Platform: All
Revision:

Description

Someone replied to my radio addon announce thread that he can't play radio stations from the favorites menu ( http://forum.xbmc.org/showthread.php?tid=119362&pid=1115612#pid1115612).

I can confirm that and tracked it down that all playable plugin favorites which don't contain at least a '?'-sign won't play.

You can easy produce with installing my radio addon (music add-on in the official repo) and add the following two entries to the favourites.xml:

<favourite name="Test 1" thumb="http://static.radio.de/images/broadcasts/2363_1.jpeg">PlayMedia(&quot;plugin://plugin.audio.radio_de/station/2363/&quot;)</favourite>
<favourite name="Test 2 (QS)" thumb="http://static.radio.de/images/broadcasts/2363_1.jpeg">PlayMedia(&quot;plugin://plugin.audio.radio_de/station/2363/?&quot;)</favourite>

The first entry won't play (but the plugin url is correct), the second one is equal except a '?'-sign is added - this one will be played. I tried to debug it myself but couldn't find the correct place in code.

setResolvedUrl() is called and gets the correct stream url for both so that's not the problem.

I hope xbmc don't assumes that every plugin url without a query string is a folder or something similar.

And please, don't simply say "plugin issue" because it is not ;)

regards, sphere

Change History

comment:1 Changed 2 years ago by sphere

I found the reason and created a possible fix for it. See details here:  https://github.com/xbmc/xbmc/pull/1032

comment:2 Changed 2 years ago by vdrfan

Can't resist.. plugin issue ;)

comment:3 Changed 2 years ago by sphere

@vdrfan: *g*

Just to have this updated: The problem was not the missing query string but the trailing slash in the plugin url. ATM plugin urls which end with a slash are recognized as folders - and if the plugin doesn't returns listitems followed by endOfDirectory(), nothing happens on opening a fav entry.

If this gets fixed in core or in every regarding plugin is not decided yet - I will keep it in sync between trac and github.

comment:4 Changed 21 months ago by Martijn

  • Priority changed from 4 - Normal to 3

still issue with latest nightly?

comment:5 Changed 21 months ago by sphere

Yes - favorite entries with a trailing slash are still recognized as folders (which can be wrong) - but this can be avoided from the plugin side. So I would close.

comment:6 Changed 21 months ago by Martijn

  • Status changed from new to closed
  • Resolution set to Obsolete
  • Milestone Future / Pending deleted
Note: See TracTickets for help on using tickets.