Ticket #13133 (closed Bugs: Incomplete (need more info))

Opened 2 years ago

Last modified 19 months ago

Video playback stop when playing mpeg-ts container files

Reported by: tsp42 Owned by:
Priority: 3 Milestone:
Component: Video playback (inc. audio in video and codecs) Version: GIT
Severity: Normal Keywords: mpeg-ts
Cc: elupus, Blocked By:
Blocking: Platform: All
Revision: 3d4ab0b0afb37e0d779093e231d6676e3fe1b3af

Description

playback of mpeg-ts files eventially stalls with the progress bar alterating +/- 1 second. The bug was first reported on opdenkamps pvr branch ( https://github.com/opdenkamp/xbmc/issues/548) but is reproducible in main as well. A sample clip is available ( http://www.mediafire.com/?ndc47hwrg2wtozg). To reproduce seek to 0:30, press rewind and then press play at 0:17. Pastebin log available here ( http://pastebin.com/6ygUUD4k).

Change History

comment:1 Changed 2 years ago by dteirney

  • Cc elupus, added

@elupus, the log for this is slightly different to the "go slow mode" I was experiencing in #12984 but the general outcome appears to be the same.

Is it possible that the same thing could be triggered by a normal seek as well as a non-flushed seek?

All the files I have had problems with have also been mpeg-ts files.

comment:2 Changed 2 years ago by dteirney

comment:3 Changed 2 years ago by FernetMenta

I have tracked this further down. ffmpeg does not observe the overflow of the 33bit pcr timestamp. ff_gen_search bails out with no error because timestamps at the end of a file get smaller.

@elupus Any idea how to get this fixed?

comment:4 Changed 21 months ago by Martijn

  • Priority changed from 4 - Normal to 3

please retry using a latest XBMC master build if you still have this issue

comment:5 Changed 19 months ago by Martijn

  • Status changed from new to closed
  • Resolution set to Incomplete (need more info)
  • Milestone Future / Pending deleted

Since there was no reply from reporter tickets will be closed.

Please try latest XBMC testing versions that can be downloaded here http://xbmc.org/download/

If issue is still present add comment to the ticket and include as much information as possible including a full debuglog Also read the FAQ  http://wiki.xbmc.org/index.php?title=XBMC_v12_%28Frodo%29_FAQ and backup your userdata when upgrading

Note: See TracTickets for help on using tickets.