Ticket #13583 (closed Bugs: Not part of XBMC (third-party))

Opened 21 months ago

Last modified 19 months ago

doesn't build against libmicrohttpd 0.9.23

Reported by: candrews Owned by:
Priority: 4 - Normal Milestone:
Component: Web Server / Web Interface / Web API / JSON-RPC Version: GIT
Severity: Normal Keywords:
Cc: Blocked By:
Blocking: Platform: Linux
Revision: 22795bcfc49b8dd0e7a66e8d3c352ccca3949511

Description

XBMC does not compile against libmicrohttpd 0.9.23 - it does compile and work fine against libmicrohttpd 0.9.22.

I'm attaching the build log.

Attachments

build.log Download (356.0 KB) - added by candrews 21 months ago.

Change History

Changed 21 months ago by candrews

comment:1 Changed 21 months ago by candrews

The error message is:

CPP     xbmc/cores/paplayer/SPCCodec.o
AR      xbmc/cores/paplayer/paplayer.a
LD      xbmc.bin
xbmc/network/network.a(WebServer.o): In function `CWebServer::AnswerToConnection(void*, MHD_Connection*, char const*, char const*, char const*, char const*, unsigned long*, void**)':
WebServer.cpp:(.text+0x2e79): undefined reference to `MHD_post_process'
WebServer.cpp:(.text+0x2f16): undefined reference to `MHD_destroy_post_processor'
WebServer.cpp:(.text+0x2ff0): undefined reference to `MHD_create_post_processor'
collect2: error: ld returned 1 exit status

comment:2 Changed 21 months ago by Montellese

Hm the definitions of these methods haven't changed between 0.9.22 and 0.9.23.

But why do you even use these versions? Debian wheezy (testing), sid (unstable), Ubuntu Quantal Quetzal (stable) and Raring Ringtail (unstable) all use 0.9.20-1.

comment:3 Changed 21 months ago by candrews

I'm using Gentoo, and they tend to update packages a bit more quickly than some of the other distros :)

In any case, XBMC will eventually hit this problem, so even if I am a bit "bleeding edge" I figured I should report the issue.

comment:4 Changed 21 months ago by Montellese

Well on win32 and osx and on any debian/ubuntu version (expect Quantal Quetzal) xbmc runs with libmicrohttpd 0.4.6 and last time someone tried to update it to 0.9.x we ran into a lot of crashes so we dropped that move for the time being. I was planning to look into moving to 0.9.20 after Frodo has been released.

comment:5 Changed 21 months ago by candrews

For what's it's worth, I've been using XBMC on linux with libmicrohttpd 0.9.22 for a while now, and I haven't had any crashing and it works for me.

comment:6 Changed 21 months ago by cinderblock

I can confirm 0.9.22 works and 23 does not.

comment:7 Changed 20 months ago by zombor

I can confirm this as well. Running gentoo also.

comment:8 Changed 19 months ago by candrews

The problem has been found and fixed in Gentoo, at least.

libmicrohttpd must be configured with "messages" support:  https://bugs.gentoo.org/show_bug.cgi?id=449082

comment:9 Changed 19 months ago by iamben

More specifically, xbmc requires libmicrohttpd built with --enable-postprocessor, which happens to be toggled with USE=messages on gentoo. IMHO this can be closed as a downstream/packaging bug. It works on older libmicrohttpd because postprocessor support wasn't optional.

comment:10 Changed 19 months ago by Montellese

  • Status changed from new to closed
  • Resolution set to Not part of XBMC (third-party)
  • Milestone Future / Pending deleted
Note: See TracTickets for help on using tickets.