Ticket #13915 (closed Bugs: Fixed)

Opened 22 months ago

Last modified 19 months ago

Filtering by FilterSMS does not work in library mode

Reported by: clutch Owned by:
Priority: 4 - Normal Milestone: 13.0 "Gotham"
Component: Graphical User Interface (GUI) Version: 12.0 "Frodo" RC3
Severity: Normal Keywords: remote
Cc: Montellese, Blocked By:
Blocking: Platform: Windows
Revision:

Description

Filtering in library mode does not work. Works fine in File mode so I think this is a bug.

My keyboard.xml  http://pastebin.com/MWbs48yx

Change History

comment:1 Changed 22 months ago by clutch

exact same setup confirmed working fine on another xbmc at v12.0 (alpha 2)

comment:2 Changed 22 months ago by ronie

debuglog or it didn't happen. ;-)

comment:3 Changed 22 months ago by clutch

01:56:45 T:2956 DEBUG: CApplication::OnKey: two (f032) pressed, action is FilterSMS2 01:56:45 T:3304 NOTICE: Thread Background Loader start, auto delete: false 01:56:45 T:3304 DEBUG: Thread Background Loader 3304 terminating

etc

Debug:  http://pastebin.com/vEG36QQz

comment:4 Changed 22 months ago by ronie

  • Cc Montellese, added

@Montellese: is this still supposed to work with the new filtering code?

comment:5 Changed 22 months ago by clutch

i think the new filtering code should be an option. it's very hard to use the filtering with a small remote with only numbers. it's a LOT faster by using the old FilterSMS-way

comment:6 Changed 22 months ago by Montellese

I'm not sure how FilterSMS works. Is it the same functionality as navigating in the list using SHIFT + typing or is it actual filtering i.e. the number of displayed items is getting less?

comment:7 Changed 22 months ago by clutch

not sure. but yes you get a smaller list as you type. 2=ABC and 3=DEF etc. so 2232 would filter "ACDC" and such if it was in listed view.

The best option would be to keep both I think.

comment:8 Changed 22 months ago by Ned Scott

There's JumpSMS which does the same thing as SHIFT + letter, but then there's FilterSMS.

comment:9 Changed 22 months ago by mou

Noticed this too. Really don't hope that this is removed intentionally.

comment:10 Changed 20 months ago by ezechiel1917

Oh, this bug is really annoying :( JumpSMS is really slow compared to filtering with FilterSMS. Hope this gets fixed soon

comment:11 Changed 20 months ago by clutch

I downgraded. I hope the XBMC fixes this.

comment:12 Changed 20 months ago by Ned Scott

I don't believe it is actually "broken". Rather, what has happened is that the advanced library filter has disabled/replaced it for certain views. In any view where the normal text filter shows up instead of the advanced filter, FilterSMS will still work. Any "fix" would basically be to somehow allow both filter methods to happen at the same time, or a switch to choose which filter method to use.

comment:13 Changed 20 months ago by ezechiel1917

It should be considered as a bug in my opinion, because now FilterSMS behaviour is pretty inconsitent between different lists. What's more important that now most of the used views (video library, music library...) always use advanced library filter, and FilterSMS does nothing there. There are some occasions where it does what it's supposed to do though (PVR) I had to remap FilterSMS to JumpSMS for libraries, but still listing trough very populated lists (thousands of items) is now real pain compared to previous blazing fast search result. And I'm talking about time difference in tens of seconds... :( I wouldn't mind turning advanced library filter off, but I don't think turning a new feature of xbmc to get different one working is proper solution. I hope this gets some attention by devs hopefully.

comment:14 Changed 19 months ago by Github Janitor

  • Status changed from new to closed
  • Resolution set to Fixed

library: support simultaneous simple and advanced filtering (fixes #13915)

Changeset: 5a37e89bf9f5a3df81ab951a06f553f18f9de850 By: montellese

comment:15 Changed 19 months ago by Github Janitor

Merge pull request #2503 from Montellese/filtering

library: support simultaneous simple and advanced filtering (fixes #13915)

Changeset: 6737e7411926da2b5e0b8a842e4c62ddbd11253d By: Martijn Kaijser

comment:16 Changed 19 months ago by Montellese

  • Milestone changed from Future / Pending to 13.0

comment:17 Changed 19 months ago by ezechiel1917

thank you!

comment:18 Changed 19 months ago by bluenote

Is there a way to stay in 'mainstream' xbmc so all addons are compatible, etc, and still get this fix? I guess I have to specify .. under Windows :) My gut tells me there is no 12.2 forthcoming, but its a long wait for 13.

I have a multiseat setup with a lot of addons so I'm very cautious about upgrade timing.

comment:19 Changed 19 months ago by Ned Scott

There will be a 12.2, but this is definitely a feature addition and technically not a bug fix, so it won't be in 12.2. Monthly and nightly builds are still fairly stable and they're still compatible with add-ons and even MySQL set-ups that are still on v12, but the real issue here is that you would have to wait for a skinner to update their skin to take advantage of the new options.

So my advice would be to grab a nightly build or the next monthly build (Alpha 3, when it comes out), and then ask on the forums in the skinning section (for whatever skin you use) if they can add the options to a test skin build, or something to that extent.

comment:20 Changed 19 months ago by Montellese

FilterSMS will work in the alpha/nightly builds without any skin adjustments. IMO skins that already support advanced library filtering shouldn't change anything. They should show the advanced filtering if available and otherwise the title filtering. FilterSMS will work independently in the background.

Note: See TracTickets for help on using tickets.