Ticket #14093 (closed Bugs: Fixed)

Opened 21 months ago

Last modified 15 months ago

XBMC 12 hangs when playing some .flv files

Reported by: eprst Owned by:
Priority: 3 Milestone: 13.0 "Gotham"
Component: Video playback (inc. audio in video and codecs) Version: 12.0 "Frodo" Final
Severity: Normal Keywords:
Cc: Blocked By:
Blocking: Platform: All
Revision:

Description

XBMC 12 fails to play some .flv files that XBMC 11 used to play without problems. I'm attaching an example.

I managed to trace it back to commit 28b186fd4621c0485608657892b7a3abcfe566ff (Merge branch 'ffmpeg_0.10.2')

This is indeed a bug in ffmpeg 0.10.2, ffplay built from this tag doesn't play this file as well. It was fixed in ffmpeg 0.11, more specifically after commit 2d9535ad317733c977a89194975f14e0cc04fb7f

Attachments

a2.flv Download (2.0 MB) - added by eprst 21 months ago.

Change History

Changed 21 months ago by eprst

comment:1 Changed 15 months ago by Martijn

  • Priority changed from 4 - Normal to 3

if possible also try out a nightly/monthly build, we need to know if it's still happening with current code so we could possibly fix it for next release). Always backup your userdata.

report if still happens

comment:2 Changed 15 months ago by eprst

XBMC 13 nightlies don't have this problem. It was a bug in ffmpeg 1.1 (used in XBMC12), bumping to 1.1.2 (used in XBMC13) resolved it

comment:3 Changed 15 months ago by Martijn

  • Status changed from new to closed
  • Resolution set to Fixed
  • Milestone changed from Future / Pending to 13.0
Note: See TracTickets for help on using tickets.