Ticket #14542 (reopened Bugs)

Opened 8 months ago

Last modified 2 days ago

MKV embedded Arabic ass subtitle

Reported by: thelordh Owned by: elupus
Priority: 4 - Normal Milestone: 13.0
Component: Video playback (inc. audio in video and codecs) Version: 12.2 "Frodo" Bugfix release
Severity: Normal Keywords: MK,ASS,Arabic
Cc: Blocked By:
Blocking: Platform: All
Revision:

Description

Hi, I hope everyone are fine, I have constantly problem with MKV Arabic ass subtitle files, Where I do have MKV videos with Arabic ASS subtitle embedded the subtitle always come inside XBMC corrupted where if play same video in "Media Classic Player" MPC the subtitle come appropriate simple figures, Please visit the thread in forum, nobody able to answer, I am desperate , this's the last resort for me ....  http://forum.xbmc.org/showthread.php?tid=171163

Attachments

screenshot005.png Download (907.8 KB) - added by Martijn 8 months ago.

Change History

comment:1 follow-up: ↓ 2 Changed 8 months ago by elupus

is this all mkv's with arabic ass subtitle or just a single one? we are likely going to need some sample to resolve this.

comment:2 in reply to: ↑ 1 Changed 8 months ago by thelordh

Replying to elupus:

is this all mkv's with arabic ass subtitle or just a single one? we are likely going to need some sample to resolve this.

Yes, for all the mkv files with embedded Arabic subtitle or ass, it give corrupted subtitle,

Please find Sample video, if play it on XBMC it will show corrupted sub, but if you play on VLC and enable arabic sub it will show appropriate sub.. [ http://www.mediafire.com/?riuy3hkbcl3575i ]I really hope it can be fixed

comment:3 follow-ups: ↓ 4 ↓ 6 Changed 8 months ago by Martijn

Subs show fine with OE Gotham alpha7 build

comment:4 in reply to: ↑ 3 Changed 8 months ago by thelordh

I just tried with xbmc 13 alpha6 and latest nightly ver.20130814,

still exactly same issue, can please share a picture for fine subtitle...

Changed 8 months ago by Martijn

comment:5 Changed 8 months ago by Martijn

added screenshot of working subs

comment:6 in reply to: ↑ 3 Changed 8 months ago by thelordh

that the corrupted subtitle not proper Arabic, if you play same video in VLC or MPC, you notice the way of display subtitle will be changed, words linked not separated such as this screen

"proper subtitle on VLC,MPC "

 http://postimg.org/image/ybb272x3n/

but in XBMC (corrupted and separated )  http://postimg.org/image/kpz8m2p7r/

hope I have describe the issue in proper way

comment:7 Changed 8 months ago by thelordh

Hi, Sorry for Disturb, But I just want to confirm the issue is clear for you guys

Thanks

comment:8 Changed 8 months ago by elupus

Yes, but we still need a sample to be able to reproduce the issue.

comment:9 Changed 8 months ago by Martijn

@elupus

He posted a link to a sample  http://www.mediafire.com/?riuy3hkbcl3575i

comment:10 Changed 8 months ago by thelordh

@Marijin @elupus, if there's anything required to closed this issue please let me know,

Regards.

comment:11 Changed 8 months ago by elupus

it seems the libass we have in depends for OSX doesn't support LIBFRIBIDI for re-ordering arabic languages.

libfribidi was added in 0.10.0, OSX runs 0.9.13.

Our internal seem to 0.10.0 (which i think is used on windows) so that should work. But i need to get OSX updated to be able to debug it.

comment:12 Changed 8 months ago by elupus

We should probably get both updated to 0.10.1 it has more fixes for bidirectional languages.

comment:13 Changed 8 months ago by thelordh

Oh, After it get updated to 0.10.1 the subtitle should works fine,but you mention something about OSX, am actually using windows XP , but I believe this problem in each platform..

You don't know how much am really happy that you find source for the problem, so I hope you don't mind to ask what would be the next is included on XBMC 13 or separate update..

Thanks a lot & appreciate your work

comment:14 Changed 8 months ago by thelordh

@elupus

comment:15 Changed 7 months ago by thelordh

Hi @Marijin & @elupus,


I hope there's a update regaed this issue,


all the best thanks

comment:16 Changed 5 months ago by Martijn

  • Status changed from new to closed
  • Resolution set to Fixed
  • Milestone changed from Future / Pending to 13.0

should be fixed by now. as you can't run Gotham on Win XP anymore and try i will just mark this fixed

comment:17 Changed 5 months ago by elupus

did we get updated libass on windows merged?

comment:18 Changed 5 months ago by Martijn

Yes Version 0.10.2

comment:19 Changed 5 months ago by thelordh

Hi,

I just check with latest 13 alpha ver.10 on windows 8 , still exact same issue, nothing has been change,

Regards.

comment:20 Changed 4 months ago by thelordh

Hi guys Once again

I have just test it latest alpha 11, it exactly same issue nothing has been change since I have raise the ticket I was putting hope this issue will be fixed in this issue but disappointed its not

Am totally understand you guys you're super busy

But this will be fix in Xbmc 13 or it will takes time @martjin @elupus

Regards

comment:21 Changed 3 months ago by elupus

  • Status changed from closed to reopened
  • Resolution Fixed deleted

comment:22 Changed 3 months ago by elupus

We'd have to find what the issue is first.

comment:23 Changed 3 months ago by thelordh

I can participate or share any data or info Required to fix the issue

Regards

comment:24 Changed 2 months ago by thelordh

Hi Seems you guys doesn't have much Interest for this problem there's no comment nor updates

comment:25 Changed 2 months ago by elupus

Hi

Well it's problematic to debug for someone who can't read arabic :).

I just tested xbmc in parallell with VLC on osx. And from what i can see the subtitles display the same way. Not in the way your screenshot shows thou.

comment:26 Changed 2 months ago by elupus

I'm pondering if it has something to do with harfbuzz not being enabled in our libass

comment:27 Changed 7 weeks ago by thelordh

Hi

I just I have try it on OSX it worked Perfectly but on windows 8 still giving me same thing

Seems only on Windows this issue

@elupus

comment:28 Changed 6 weeks ago by thelordh

Hi

I hope you have got an update, Since that issue already resolved On OSX Maybe will easy to track source of problem in Windows

Guys if I can help please let me know....7 months already passed

I hope it will fix soo :(

comment:29 Changed 12 days ago by thelordh

Gentle remainder guys

comment:30 Changed 2 days ago by thelordh

Any way guys

Thanks for corporation I have lost the hope for fixing this Problem if want close the ticket please proceed I know you have high priority stuff

Note: See TracTickets for help on using tickets.