Ticket #14954 (new Bugs)

Opened 6 months ago

Last modified 3 months ago

Wake on access (WOA) not working in main menu shortcuts

Reported by: sandreas Owned by: jmarshall
Priority: 4 - Normal Milestone: Future / Pending
Component: Database / Library for Videos (Movies and TV-Shows) Version: 13.0 "Gotham" Final
Severity: Normal Keywords: wake on access
Cc: t4_ravenbird, althekiller, Blocked By:
Blocking: Platform: All
Revision:

Description

When selecting a movie, a series or music in main menu library shortcuts, no wol package is triggered, if the movie is placed on a share (see screenshot) and xbmc hangs.

Wake on access out of the file browser or database browser works as expected.

Attachments

screenshot.jpg Download (121.5 KB) - added by sandreas 6 months ago.
Selecting "play" for a movie does not trigger wol-package

Change History

Changed 6 months ago by sandreas

Selecting "play" for a movie does not trigger wol-package

comment:1 Changed 6 months ago by Martijn

  • Cc t4_ravenbird, althekiller, added

comment:2 Changed 6 months ago by t4_ravenbird

When I try this I find that WOA kicks in and does what it should but in the background ; there is not the ordinary visual feedback (progressdialog) during wakeup - and I guess that is what this ticket is about. When I look in log-file I observe that after clicking a movie, a new DVDPlayer thread is spawn and that this thread is the only one accessing the file. WOA will by design do wakeup-sequence 'invisible' when not on GUI thread so this is as expected. A possible workaround could be to have the GUI-thread access the movie before starting the background-thread??

-- 59768 is gui thread --

09:27:23 T:59768  NOTICE: DVDPlayer: Opening: smb://10.0.0.6/xbmc_movies/.............
09:27:23 T:59768 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
09:27:23 T:59768   DEBUG: CRenderManager::UpdateDisplayLatency - Latency set to 0 msec
09:27:23 T:73188  NOTICE: Thread DVDPlayer start, auto delete: false
09:27:23 T:73188  NOTICE: Creating InputStream
09:27:25 T:73188  NOTICE: WakeOnAccess [10.0.0.6] trigged by accessing : smb://10.0.0.6/xbmc_movies/.........
09:27:25 T:59768   DEBUG: ------ Window Init (DialogBusy.xml) ------
09:27:25 T:59768   DEBUG: Window DialogBusy.xml was already loaded

comment:3 Changed 3 months ago by Martijn

retest with Gotham 13.0

comment:4 Changed 3 months ago by t4_ravenbird

still there (oe 4.0.1)
I still recommend pr  https://github.com/xbmc/xbmc/pull/4256 to fix it

comment:5 Changed 3 months ago by Martijn

  • Version changed from 13.0 "Gotham" Alpha10 to 13.0 "Gotham" Final
Note: See TracTickets for help on using tickets.