Ticket #14977 (closed Bugs: Won't be fixed/added)

Opened 9 months ago

Last modified 9 months ago

Firewall on 10.9.x nagging on XBMC listening ports

Reported by: Memphiz Owned by: davilla
Priority: 4 - Normal Milestone:
Component: Mac OS X specific feature Version: 12.2 "Frodo" Bugfix release
Severity: Normal Keywords:
Cc: davilla, jmarshall Blocked By:
Blocking: Platform: All
Revision:

Description (last modified by Memphiz) (diff)

As soon as one of our servers gets turned on the firewall nags on each start - and it doesn't remember the setting to not nag again.

Based on user information this only happens with XBMC [tm] and all other programs are fine (of course!).

Change History

comment:1 Changed 9 months ago by Memphiz

  • Owner changed from Koying to davilla
  • Component changed from Android specific feature to Mac OS X specific feature

comment:2 Changed 9 months ago by FernetMenta

At devcon I mentioned that new audio settings break backwards compatibility. This is works as designed, not a bug. An upgrade script could delete the old audio settings section from guisettings

comment:3 Changed 9 months ago by Ned Scott

I think the real issue is that it seems to be causing a firewall issue in OS X, which seems unlikely to me, but I guess stranger things have happened.

comment:4 Changed 9 months ago by Memphiz

  • Cc natethomas, added

@natethomas

Can you ensure to mention that we suggest to cleanout the guisettings.xml when upgrading to Gotham? I don't want to deal with migration issues this time (it was demanding a bit of support in frodo already and i want to prevent the time waste this time).

comment:5 Changed 9 months ago by Martijn

  • Cc jmarshall added

i thought all old settings became just useless and were never used again as they were renamed?

if this is not the case we should incorporate an update clause in core that removes old settings. we cannot ask people to manually clean guisettings or totally destroy it.

comment:6 Changed 9 months ago by Ned Scott

It seems the old settings left over are, in fact, unrelated to the firewall popup issue on Mac OS X. So yes, the old settings shouldn't be an issue in this case.

comment:7 Changed 9 months ago by Memphiz

  • Cc fritsch, FernetMenta, natethomas, removed
  • Status changed from new to closed
  • Resolution set to Won't be fixed/added
  • Description modified (diff)
  • Summary changed from Audiosettings migration from older setups to gotham to Firewall on 10.9.x nagging on XBMC listening ports

comment:8 Changed 9 months ago by Memphiz

  • Milestone Future / Pending deleted

comment:9 Changed 9 months ago by Memphiz

Stupid trac. This ticket was about settings migration - thats what i wanted to close with "wontfix" - somehow it got mixed up with the new ticket about firewall issue *grr*.

Note: See TracTickets for help on using tickets.