Ticket #5205 (closed Bugs)

Opened 6 years ago

Last modified 2 years ago

No sound with some OGM container videos

Reported by: largo77 Owned by: elupus
Priority: 4 - Normal Milestone:
Component: Video playback (inc. audio in video and codecs) Version: GIT
Severity: Normal Keywords:
Cc: VDRfan Blocked By:
Blocking: Platform: All
Revision:

Description

Hello!

I have a few videos from which XBMC (Atlantis Beta 2) seems to be unable to play the sound. The videos are all dual audio (English and Japanese) and XBMC can't play both languages, however they work fine when I play then with VCL (0.8.6i) or an older version of XBMC on my Xbox including switching the language.

Logfile:

 http://pastebin.com/m140a3484

Attachments

[a-s]_Slayers_Gorgeous_sample.ogm Download (9.5 MB) - added by largo77 6 years ago.
XBMC_2010-01-23-114646_Sean-Sorias-MacBook-Pro.crash Download (38.7 KB) - added by malloc 5 years ago.

Change History

comment:1 follow-up: ↓ 2 Changed 6 years ago by jmarshall

Can you please post a sample here (or a link to one). Thanks.

Changed 6 years ago by largo77

comment:2 in reply to: ↑ 1 Changed 6 years ago by largo77

Replying to jmarshall:

Can you please post a sample here (or a link to one). Thanks.

I was already on it, just the connection got lost a few times and I had to start the upload again ;)

comment:3 Changed 6 years ago by jmarshall

  • Owner set to elupus
  • Status changed from new to assigned

Thanks. I've confirmed the problem - it appears the version of libfaad we use doesn't handle this track. I tried updating libfaad to the latest version (2.6.1) and built that fine for win32 (had to alter the solution file + add a couple of exports to the .def). It still doesn't work with that version though - we get the same errors in fact.

comment:4 Changed 6 years ago by WiSo

  • Cc vdrfan added

vdrfan would you mind testing if this is a windows only or a general libfaad problem?

comment:5 Changed 6 years ago by WiSo

Tested the demo file with vlc 0.9.4 and it doesn't work there too. No audio on both tracks.

comment:6 Changed 6 years ago by WiSo

  • Cc VDRfan added; vdrfan removed

comment:7 Changed 6 years ago by VDRfan

  • Platform changed from Windows to All

XBMC for Linux will crash once the playback ended on the sample file. This will only happen if ..

Option      "OpenGLOverlay" "on"

.. is set in xorg.conf (fglrx - Radeon HD 2400 XT)

log:  http://pastebin.com/f17be2e46 backtrace:  http://pastebin.com/f7ea2c420

comment:8 Changed 6 years ago by VDRfan

ok, keeps crashing regardless of xorg.conf options. sorry ..

comment:9 Changed 6 years ago by VDRfan

  • Version changed from Atlantis Beta 2 to SVN

comment:10 Changed 6 years ago by sho

  • Milestone set to 9.04

comment:11 Changed 6 years ago by sho

  • Component changed from Other (un-categorized) to Video playback (inc. audio in video)

comment:12 Changed 6 years ago by theuni

  • Priority changed from 4 - Normal to 6

An impressive combination of bugs here...

  1. No sound
  2. Video Corruption (see ~5 secs)
  3. Subtitles appear to be way off
  4. Crashes or hangs at some point

FFPlay fares very poorly as well. Current mplayer doesn't suffer from these problems.

Is there a root cause here, or should these things be split off into separate issues?

Bumping priority for crash\hang.

comment:13 Changed 5 years ago by malloc

Well, this just freeze XBMC 9.11 on OSX. Definitely still a bug.

comment:14 Changed 5 years ago by malloc

Retested with r27056. No audio was played and crash occurred a few seconds in. Attaching crash log.

Changed 5 years ago by malloc

comment:15 Changed 5 years ago by vdrfan

  • Priority changed from 6 to 4 - Normal

comment:16 Changed 3 years ago by spiff

will be fixed when 7c8d477299c9b5e89fc30ed22f9e42b50761342c is pulled from ffmpeg upstream.

comment:17 Changed 2 years ago by Martijn

  • Status changed from assigned to closed

comment:18 Changed 2 years ago by sho

  • Milestone Future / Pending deleted
Note: See TracTickets for help on using tickets.